Traveling Internationally and Multifactor Authentication

Problem

Traveling Abroad?  If you are preparing to travel abroad, be sure to follow the tips below to avoid any issues with accessing your TU accounts and email when you arrive at your destination:

Environment (ie: Product build, OS, Software, Firewall, Proxy, Internet Service Provider, etc)

 

Resolution

 

  1.  Add a secondary contact method to Multifactor Authentication (MFA)
    1. Using an Internet Browser, go to https://mysignins.microsoft.com/
    2. Once at this screen, use the menu on the left and CLICK on "Security Info"
    3. Add the second contact method – office phone or cell phone, or Authenticator app if you selected to use a phone initially.

 

  1. Check the “alternate” or personal email that is on file with the University
    1. You can find this by logging into Self-Service from the Applications page
    2. Click on your TUNetID (abc1234) in the top right
    3. Select User Profile
    4. Find the email section and review the email addresses to make sure the information is correct and that you have access to both accounts
    5. Ensuring you have an alternate email address you can access will enable you to reset your account password without any assistance

 

  1. Before you travel, download, and set up the Microsoft Authenticator App on your mobile device.

 

  1. If you plan to purchase a new international phone / device when you arrive, be sure to bring your domestic phone / device with you so you can authenticate over Wi-Fi when you arrive in your destination. 

Cause

 

Contact Information

If you're still having trouble, submit a ticket here or call us at 918-631-3500